The following warnings occurred:
Warning [2] Illegal string offset 'birthday' - Line: 105 - File: inc/plugins/imagebirthday.php PHP 5.5.38 (Linux)
File Line Function
/inc/plugins/imagebirthday.php 105 errorHandler->error
[PHP]   imagebirthday_profile
/inc/class_plugins.php 100 call_user_func_array
/showthread.php 394 pluginSystem->run_hooks
Warning [2] Illegal string offset 'birthday' - Line: 105 - File: inc/plugins/imagebirthday.php PHP 5.5.38 (Linux)
File Line Function
/inc/plugins/imagebirthday.php 105 errorHandler->error
[PHP]   imagebirthday_profile
/inc/class_plugins.php 100 call_user_func_array
/showthread.php 1245 pluginSystem->run_hooks





 We have received 33% of our goal
Server costs


Forum Affiliates

Your banner here / Tu banner aquí

Tags: Images, dont, open, posts,
Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Images don't open in posts?
07-05-2011, 01:30 PM
Post: #1
Brick Images don't open in posts?
0
0
I've encountered a problem.. I can't see images attached with posts if they're uploaded to EDCMF server (such as Jalbams, no pun intended). There's only a line of text (in HTML I guess) and no picture. Hosted images (TinyPic, etc) are opening correctly.

However when I write reply to a post, image is visible in the preview field.

I've tried disabling AdBlock, but there's no change. I'm running Linux, but never had any problems with it on other forums

Any help would be appreciated, thanks.

Cheers,

Tam

EDCMF #17
Find all posts by this user
Quote this message in a reply
07-05-2011, 01:37 PM
Post: #2
RE: Images don't open in posts?
0
0
Thank you very much for your information.

I am so sorry I don't know what this happens. Could you tell me the address of one or more threads that is happening this? That way it will be easier for me to reproduce the error in my computer and find out how to deal with this.

If you can and want, screenshot would be much appreciated too.

I hope I can fix it soon! Smile

EDC Mania: Your Every Day Carry forums! Smile
Visit this user's website Find all posts by this user
Quote this message in a reply
07-05-2011, 03:11 PM
Post: #3
RE: Images don't open in posts?
0
0
First I've noticed that here:

http://edcmania.com/forum/Thread-jalbam-s-EDC

And this is how it looks:

[Image: mjwn13.jpg]

Cheers,

Tam

EDCMF #17
Find all posts by this user
Quote this message in a reply
07-05-2011, 04:53 PM
Post: #4
RE: Images don't open in posts?
0
0
Thanks! Smile

That's was very strange at first, but I have found out the reason.

In my computer works when I am logged in but it shows the "[Image: attachment.php?aid=" when I am not (when I visit as a guest the forum with another browser, for example).

Images should work for everyone. The problem is that to show that images I did a little trick: I uploaded them as attachments and then I edited post writing IMG tag pointing to the URL of the image attached.

Then this is not a normal image and it's treated as an attachment. The problem is that it should works always for everyone except for banned, guests, awaiting activation people and registered ones who has not yet introduced to the forum (those who has never written anything). This is not your case and it should work for you.

Does that happen to you when you are logged in? It shouldn't since you have the status of "Introduced and participative" and you have access to all the attachments.

Are you also able to visit restricted zones as for example "Want to sale", etc? You should be able too. Please let me know.

Thanks, now I know the problem and it's just a question of time to find out why it's failing and see how to solve it.

I am wondering if it's a problem with accounts permission or with another configuration.

EDC Mania: Your Every Day Carry forums! Smile
Visit this user's website Find all posts by this user
Quote this message in a reply
07-05-2011, 05:49 PM
Post: #5
RE: Images don't open in posts?
0
0
(07-05-2011 04:53 PM)edcmania Wrote:  Does that happen to you when you are logged in? It shouldn't since you have the status of "Introduced and participative" and you have access to all the attachments.

Are you also able to visit restricted zones as for example "Want to sale", etc? You should be able too. Please let me know.

Images are showing just fine when I'm logged in. I also have access to the restricted zones (trading part of the forum)

I even booted the WinXP instead of Linux and still had the same issue, but it seems now that it must be the matter of being logged in or not Blush

Sorry for the inconvenience,

Tam

EDCMF #17
Find all posts by this user
Quote this message in a reply
07-05-2011, 08:36 PM (This post was last modified: 07-05-2011 08:37 PM by edcmania.)
Post: #6
RE: Images don't open in posts?
0
0
Don't worry, thank you very much for your information. I wouldn't have found out that mistake if it wasn't for you.

In fact it's my fault, I shouldn't have used that way to post the images. I am sorry.

1) This is the method I used (I don't recommend it since it produces that problems):
* Attach the images and send the post.
* Find out the address of the images (viewing the source code or using right click, depending on the browser).
* Edit the post and use tag IMG to point to the images using that addresses.

2) This is the recommended method (I think it's better because everyone, even unlogged, can see at least the thumbnails, but I am not sure about that):
* Attach the images and insert them in the text if you want with the button that does that.

3) There is another one (I don't recommend it since it depends on external servers that can shutdown or delete the images):
* Upload the images to another server.
* Use the tag IMG to point to them.

With the second method, the images will show as a thumbnail but will zoom when you click them (I think some people, as guests, can't click them). With the first one, the images show bigger (that's why I used that method first) and can be used in more than one post without having to upload them more than once, but produces that problems you pointed at.

Next images I will attach them using second method, I promise it! Smile

EDC Mania: Your Every Day Carry forums! Smile
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Images don't open in posts?
Current time: 12-10-2018, 10:23 PM
User(s) browsing this thread: 1 Guest(s)
Author: tam
Last Post: edcmania
Replies 5
Views 647


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Links
Budget Light Forum

Search Forums

(Advanced Search)

More
Gearoo - EDC Shop
Gearoo - Tienda EDC

Latest Threads
Caravan Designs Brand Sug...
Last Post: Caravan-Designs
11-05-2018 09:34 PM
» Replies: 0
» Views: 0
Hello From Caravan Design...
Last Post: Caravan-Designs
11-02-2018 01:54 AM
» Replies: 0
» Views: 0
Hello Everyone
Last Post: KenkoyCreator
10-07-2016 12:21 AM
» Replies: 0
» Views: 0
Hello everyone
Last Post: eirselloo
03-08-2015 05:57 PM
» Replies: 0
» Views: 1
Greetings fellow EDCeers
Last Post: tam
01-02-2015 07:17 AM
» Replies: 1
» Views: 4
Greeting from Virginia
Last Post: Gsd2012
07-08-2014 10:14 PM
» Replies: 0
» Views: 4
Wenger Evolution ST 10 mi...
Last Post: tam
03-07-2014 05:10 PM
» Replies: 0
» Views: 10
Which one from Maglite li...
Last Post: tam
03-05-2014 04:52 PM
» Replies: 1
» Views: 7
The falshlight batteries ...
Last Post: Tibo
01-14-2014 06:19 AM
» Replies: 0
» Views: 107
Cheap EDC tactical pen
Last Post: edcmania
12-18-2013 10:46 AM
» Replies: 0
» Views: 137

Online Users
There are currently 6 online users.
» 0 Member(s) | 6 Guest(s)